Willkommen, Gast
Benutzername: Passwort: Angemeldet bleiben:

THEMA: Sketch wird nicht auf ESP8266 geladen

Sketch wird nicht auf ESP8266 geladen 16 Feb 2018 20:04 #369

  • Egwe
  • Egwes Avatar
  • Offline
  • New Member
  • Beiträge: 1
  • Karma: 0
Hallo liebe ESP8266-Community,
ich habe mir vor kurzen ein NodeMCU mit ESP-12F zugelegt und wollte diesen nun mittels der Arduino IDE mit dem Beispielsketch Boards_Wifi>NodeMCU der Blynk Library bespielen.
Kompiliert wurde der Sketch, aber beim Hochladen kam folgende Fehlermeldung:

"Arduino: 1.8.5 (Windows 10), Board: "NodeMCU 1.0 (ESP-12E Module), 80 MHz, 4M (1M SPIFFS), v2 Prebuilt (MSS=536), Disabled, None, 115200"

Archiving built core (caching) in: C:\Users\Jonathan\AppData\Local\Temp\arduino_cache_45363\core\core_esp8266_esp8266_nodemcuv2_CpuFrequency_80,FlashSize_4M1M,LwIPVariant_v2mss536,Debug_Disabled,DebugLevel_None____,UploadSpeed_115200_21133218d9673a2aa04bcf12235f0cd1.a
Der Sketch verwendet 264867 Bytes (25%) des Programmspeicherplatzes. Das Maximum sind 1044464 Bytes.
Globale Variablen verwenden 35500 Bytes (43%) des dynamischen Speichers, 46420 Bytes für lokale Variablen verbleiben. Das Maximum sind 81920 Bytes.
Uploading 269008 bytes from C:\Users\Jonathan\AppData\Local\Temp\arduino_build_221974/NodeMCU.ino.bin to flash at 0x00000000
warning: espcomm_send_command: didn't receive command response
warning: espcomm_send_command(FLASH_DOWNLOAD_BEGIN) failed
error: espcomm_upload_mem failed
error: espcomm_upload_mem failed"


Ich habe bereits versucht mich in anderen Beiträgen in anderen Foren zu informieren, bin dadurch aber auch nicht schlauer geworden. Vielen Dank im Voraus schon einmal.

Gruß Jonathan
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Sketch wird nicht auf ESP8266 geladen 17 Feb 2018 07:23 #370

  • supportteam
  • supportteams Avatar
  • Offline
  • Administrator
  • Beiträge: 7
  • Karma: 0
Guten Morgen, Jonathan,

...und herzlich Willkommen im Forum :-)

Diese Fehlermeldung kommt tatsächlich auch des öfteren, wenn "einfach mal so" zwischendurch der Upload nicht klappt. Der ESP ist bezüglich des Uploads nicht so zuverlässig.
Wiederholtes probieren hilft!
Ansonsten stelle Deine IDE mal um auf
Board: Generic ESP8266 Module
Reset Method: nodemcu

Ansonsten verliert das Board auch gerne mal den Bezug zum eingestellten Serialport. Du erkennst es am Haken am richtigen Port unter "Port".
Ansonsten probiere es an einem andderen Port (falls weitere angeboten werden). Bei Windows werden Dir oftmals eine ganze Reihe von Serialports angeboten. In der Regel ist es der Port mit der höchsten Zahl.

Viele Grüße

Jörg
Letzte Änderung: 17 Feb 2018 07:25 von supportteam.
Der Administrator hat öffentliche Schreibrechte deaktiviert.
Diese Seite verwendet Cookies weche nach Ihrem Besuch automatisch gelöscht werden (sog.Session Cookies)! Durch die Nutzung dieser Website erklären Sie sich mit der Verwendung von Cookies einverstanden.
EINVERSTANDEN